PAT-A 1047 Student List for Course (25)

  对不起,我再也不敢用 cout 了。

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Problem: PAT-A 1047 Student List for Course

Input Specification

Each input file contains one test case. For each case, the first line contains 2 numbers: $N(≤40,000)$, the total number of students, and $K(≤2,500)$, the total number of courses. Then $N$ lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number $C(≤20)$ which is the number of courses that this student has registered, and then followed by $C$ course numbers. For the sake of simplicity, the courses are numbered from 1 to $K$ .

Output Specification

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.

Sample Input

1
2
3
4
5
6
7
8
9
10
11
10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

Analysis

  水题,排序完输出即可。

  cout 会超时,关闭同步也没用,老老实实用 scanf 和 printf。

Code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
#include <bits/stdc++.h>
using namespace std;

vector<string> G[2505];

int main() {
ios::sync_with_stdio(false);
cin.tie(0);
int N, K;
cin >> N >> K;
for (int i = 0; i < N; i++) {
string stu;
int C;
cin >> stu >> C;
while (C--) {
int crs;
cin >> crs;
G[crs].push_back(stu);
}
}
for (int i = 1; i <= K; i++) {
int len = G[i].size();
printf("%d %d\n", i, len);
sort(G[i].begin(), G[i].end());
for (int j = 0; j < len; j++) {
printf("%s\n", G[i][j].c_str());
}
}
}

Tsukkomi

  在刷 PAT 甲级之前只被 cin 绊过,以为关闭同步就万事大吉了。事实证明 cin/cout 确实比 scanf/printf 要慢的,输入输出数据量大的时候老老实实用后者。


#
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×