PAT-A 1018 Public Bike Management (30)

  阅读理解。使用 Dijkstra 获取所有最短路径;使用 DFS 遍历获取最优解。

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at $S_3$, we have 2 different shortest paths:

  1. PBMC -> $S_1$ -> $S_3$. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from $S_1$ and then take 5 bikes to $S_​3$, so that both stations will be in perfect conditions.
  2. PBMC -> $S_2$ -> $S_3$. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Problem: PAT-A 1018 Public Bike Management

Input Specification

Each input file contains one test case. For each case, the first line contains 4 numbers: $C_{max}$ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; $S_p$, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers $C_i$(i=1,⋯,N) where each $C_i$ is the current number of bikes at $S_i$ respectively. Then M lines follow, each contains 3 numbers: $S_i$, $S_j$, and $T_{ij}$ which describe the time $T_​{ij}$ taken to move betwen stations $S_i$ and $S_j$ . All the numbers in a line are separated by a space.

Output Specification

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>$S_1$−>⋯−>$S_p$. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of $S_p$ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge’s data guarantee that such a path is unique.

Sample Input

1
2
3
4
5
6
7
10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output

1
3 0->2->3 0

Analysis

  题目大意:共享单车调度,要求每个车站的共享单车数量为总容量的一半。当一个车站需要调度时,从管理中心出发,选择最短路线到达该车站,如果最短路线存在多条,那么选择从管理中心派送最少车辆的路线,途经的每个车站都要顺便把它调整为半满。例如 $S_3$ 缺 5 辆,沿途可从 $S_2$ 取走 2 辆给 $S_3$,因此只需要从管理中心取 3 辆,两个车站均达到半满。输出需要派送的最少单车数量,按格式输出路线,最后输出带回管理中心的最少单车数量。

  使用 Dijkstra 算法获取最短路径,记录路径中每个结点的前置结点。因为有距离相同的情况,使用二维数组保存前置结点,从而获得多条路径。使用 DFS 对所有最短路径进行遍历,比较每条路径的派送和带回单车的数量,获得最少派送数量和最少派送条件下的最少带回数量。

  坑: 行驶路线是单向无往返的,也就是从管理中心出发,每到一个车站就要将该车站的单车数量调整为半满,不能利用返程调整。例如:总容量为 10,$S_1$为 2,$S_2$为 8,路线 PBMC->$S_1$->$S_2$,不能从$S_2$取 3 辆调度到 $S_1$,需要从管理中心派送 3 辆,并带回 3 辆。

Code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
#include <bits/stdc++.h>
using namespace std;
const int mxN = 505;

int C, N, S, M, G[mxN][mxN], w[mxN], d[mxN];
vector<int> pre[mxN], path, tmp_path;
bool vis[mxN];

void dijkstra(int s) {
fill(d, d + mxN, INT_MAX);
d[s] = 0;
for (int i = 0; i <= N; i++) {
int u = -1, mnD = INT_MAX;
for (int j = 0; j <= N; j++) {
if (!vis[j] && d[j] < mnD) {
mnD = d[j];
u = j;
}
}
if (u == -1) return;
vis[u] = true;
for (int v = 0; v <= N; v++) {
if (!vis[v] && G[u][v] != INT_MAX) {
if (d[u] + G[u][v] < d[v]) {
d[v] = d[u] + G[u][v];
pre[v].clear();
pre[v].push_back(u);
} else if (d[u] + G[u][v] == d[v]) {
pre[v].push_back(u);
}
}
}
}
}

int min_bk = INT_MAX, min_sd = INT_MAX;
void dfs(int v) {
tmp_path.push_back(v);
if (v == 0) {
int len = tmp_path.size(), bk = 0, sd = 0;
for (int i = len - 2; i >= 0; i--) { // 去掉出发点
int num = w[tmp_path[i]] - C / 2; // 当前车站的数量情况
if (num < 0) { // 缺车
if (-num > bk) {
sd += -num - bk;
bk = 0;
} else {
bk += num;
}
} else if (num > 0) { // 多车
bk += num;
}
}
if (sd < min_sd) {
min_sd = sd;
min_bk = bk;
path = tmp_path;
} else if (sd == min_sd && bk < min_bk) {
min_bk = bk;
path = tmp_path;
}
}
int len = pre[v].size();
for (int i = 0; i < len; i++) {
dfs(pre[v][i]);
}
tmp_path.pop_back();
}

int main() {
ios::sync_with_stdio(false);
cin.tie(0);
fill (G[0], G[0] + mxN * mxN, INT_MAX);
cin >> C >> N >> S >> M;
for (int i = 1; i <= N; i++) {
cin >> w[i]; // 单车数量
}
for (int i = 0; i < M; i++) {
int a, b, t;
cin >> a >> b >> t;
G[a][b] = G[b][a] = t;
}
dijkstra(0);
dfs(S);
cout << min_sd << " ";
int len = path.size();
for (int i = len - 1; i >= 0; i--) {
if (i < len - 1) cout << "->";
cout << path[i];
}
cout << " " << min_bk << endl;
}

Tsukkomi

  瞎脑补了一堆骚操作,怼了一个多小时,测试点就只过一半。网上搜大佬题解才知道自己加戏了,路程是单向的…… 另外题目说明了要选择从管理中心派送单车数量最少的路线,如果存在多条路线派送数量相同,那么选带回单车数量最少的。


#
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×