PAT-A 1016 Phone Bills (25)

  结构体排序。

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Problem: PAT-A 1016 Phone Bills

Input Specification

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number $N(≤1000)$, followed by $N$ lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input

1
2
3
4
5
6
7
8
9
10
11
12
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output

1
2
3
4
5
6
7
8
9
10
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

Analysis

  题目大意:计算用户的通话账单,首先给出 24 小时中每小时的收费标准。然后给出用户的接通和挂断的时间记录,接通和挂断必须按时间顺序相互匹配,否则无视。最后按格式输出用户的通话记录、通话时长、费用等信息。

  创建结构体保存每条通话记录的用户名、时间及状态,将所有通话记录按用户名从小到大排序,用户名相同的按记录时间排序。然后遍历排序后的通话记录 $V$,如果 $V_i$ 与 $V_{i+1}$ 用户名相同,且一个接听一个挂断,则匹配成功。先输出用户名和月份,如果已输出则跳过,之后计算这一对记录的通话时长和费用并按要求输出记录。当一个用户的账单信息输出结束,输出该用户的总费用。具体见代码。

坑及注意事项

  • 所有数据均在同一月,不需要对月份处理。
  • 通话记录存在跨日的,需要特别判断。
  • string 必须用 cin/cout,否则就用 char[]。

Code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
#include <bits/stdc++.h>
using namespace std;

struct Rec {
char name[25];
int dd, HH, mm, time;
bool on;
bool operator < (const Rec &x) const {
return (strcmp(name, x.name) == 0 ? time < x.time : strcmp(name, x.name) < 0);
}
};

int N, c[25];
vector<Rec> v(1005);

double GetCharge(Rec A, Rec B) {
double res = 0;
while (A.dd != B.dd || A.HH != B.HH || A.mm != B.mm) {
if (A.dd == B.dd && A.HH == B.HH) {
res += c[A.HH] * (B.mm - A.mm);
A.mm = B.mm;
} else {
res += c[A.HH] * (60 - A.mm);
A.mm = 0;
if (A.HH == 23) {
A.HH = 0;
A.dd++;
} else {
A.HH++;
}
}
}
return res / 100;
}

int main() {
for (int i = 0; i < 24; i++) {
scanf("%d", &c[i]);
}
scanf("%d", &N);
int MM;
char sign[10];
for (int i = 0; i < N; i++) {
scanf("%s %d:%d:%d:%d %s", v[i].name, &MM, &v[i].dd, &v[i].HH, &v[i].mm, sign);
v[i].time = (v[i].dd * 24 + v[i].HH) * 60 + v[i].mm;
if (sign[1] == 'n') v[i].on = true;
else v[i].on = false;
}
sort(v.begin(), v.begin() + N);
int flag = 0;
double total_amt = 0;
for (int i = 0; i < N - 1; i++) {
if (strcmp(v[i].name, v[i + 1].name) == 0 && v[i].on && !v[i + 1].on) {
if (!flag) {
printf("%s %02d\n", v[i].name, MM);
flag = 1;
}
double chag = GetCharge(v[i], v[i + 1]);
printf("%02d:%02d:%02d %02d:%02d:%02d ", v[i].dd, v[i].HH, v[i].mm, v[i + 1].dd, v[i + 1].HH, v[i + 1].mm);
printf("%d $%.2f\n", v[i + 1].time - v[i].time, chag);
total_amt += chag;
} else if (strcmp(v[i].name, v[i + 1].name)){
if (flag) {
printf("Total amount: $%.2f\n", total_amt);
}
flag = total_amt = 0;
}
}
if (flag) {
printf("Total amount: $%.2f\n", total_amt);
}
}

Tsukkomi

  起初我的 string 类型是先 resize 然后按地址用 scanf 输入的,输出的时候用 printf 配合 c_str(),然鹅样例过了,交上去却全是错的。我以为是有逻辑错误,就在网上查,看到有人说费用为 0 的不能输出,于是我就先处理信息再输出,结果还是全错。然后看到有人说 string 不能用,我就把涉及 string 的输入/输出改成了 cin/cout,结果交上去真的 AC 了???最后证明测试点中并没有费用为 0 不输出的坑,string 的坑是有的,虽然暂时不清楚为什么。

  但是 u1s1,作为一道 25 分的题,确实有点恶心了。


#
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×